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LAB 3 - Geometry Annotation

This lab demonstrates how annotate horizontal geometry, set and display alignment stationing, and use 
horizontal alignment tracking tools.

Chapter Objectives:

 Display horizontal alignments.

 Annotate horizontal alignments and cogo points.

 Reset stationing on an alignment.

 Display stationing.

 Add a station equation.

 Use Tracking and Horizontal Alignments Tracking.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Geometry-
Annotation.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

Lab 3.1 - Geometry Display

Section Objectives:

 Set the proper scale factors.

 Open a saved view in MicroStation.

 Display alignments using the View and Annotation commands.

1. Select Tools > Global Scale Factors and set the scales to 100 for Text and Cell and 1 
for Line Style.

2. <D> Apply then Close to accept the changes and dismiss the dialog box.

3. Using the MicroStation menus, select Utilities > Saved Views to open the saved views 
dialog box.
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4. <D> on the name POB, <D> the Apply Saved View button, then <D> in View 1.

5. Close the Saved Views dialog box.

Below is an example of the saved view. Only two small symbols are visible.
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6. Display alignment SH 86_West from the Geometry Project 12345_Design by right-
clicking <R> on the alignment name and selecting View from the right click menu.
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The alignment display is based on the geometry style assigned to the alignment. This 
display method does not allow the user to annotate of the geometry. The next steps 
illustrate how to display various types of horizontal alignment data.

7. Select Geometry > View Geometry > Horizontal Annotation.

8. Key in SH 86_West in the Annotate field and Tab from the field.

9. Set options for the Display and Annotate sections of the dialog box as shown in the above 
illustration.

10. <D> the Apply button. The SH86_West alignment and its annotation are displayed.
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11. Note how Bearing and Distance annotation is displayed along the tangents. If the 
alignment contains horizontal curves, curve data will be displayed.

12. Return to the View Horizontal Annotation dialog box.
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13. In the Annotate area of the Main tab, Toggle on Points and <D> Apply

In addition to annotation for tangents and curves, notice that alignment vertices are also 
annotated.
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14. On the Main tab, click the Help button and review the descriptions for the various 
components that can be displayed.

15. Experiment displaying an alignment with Points and Elements turned on or off in both the 
Display area and the Annotate area.

16. Close the View Horizontal Annotation dialog box.

Section Summary:

 InRoads displayed graphics are governed by the Global Scale Factor in InRoads. The 
MicroStation Annotation Scale has no affect on these elements.

 The view alignment commands (from the right click menu or from Geometry > View 
Geometry > Active Horizontal) only display the lines and arcs that make of the alignments 
path.

 Horizontal Annotation also displays the alignment’s path and it can display other geometry 
data as well.

Lab 3.2 - Selecting Multiple Alignments for display and/or 
Annotation

Section Objectives:

 Illustrate how to display and annotate multiple horizontal alignments at one time.

1. Select Geometry > View Geometry > Horizontal Annotation.



Page 56 Colorado Department of Transportation

LAB 3 - Geometry Annotation Labs for InRoads V8i SS2

2. <D> the Main tab.

3. Set the Apply Style to Assigned.

4. <D> in the Include field in the Horizontal Alignments area. The Filter button becomes 
active.

5. <D> the Filter button to display the Geometry Selection Filter dialog box.

Note: Available alignments are shown on the left, Selected (for display or annotation) 
alignments are shown on the right. This makes it possible to select multiple 
alignments for display or annotation.



Colorado Department of Transportation   Page 57

Labs for InRoads V8i SS2 LAB 3 - Geometry Annotation

6. Move the alignments SH 86_West and Side Road from the Available list to the Selected 
list by highlighting their names in the Available list and then <D> the ADD button (or 
<D><D> on the names).

Note: To sort the data in this dialog box, <D> on the column headers. To select multiple 
alignments use of the <CTRL> or <Shift> keys.

7. <D> OK to dismiss the Geometry Selection Filter dialog box and populate the Horizontal 
Alignments Selected field of the View Horizontal Annotation dialog box.

8. <D> Apply and the selected alignments are displayed in MicroStation.
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9. Review the results in MicroStation.

Section Summary:

 Alignments can be selected for annotation by key in, graphic selection using the  button, 
or by using the Filter options.

  The Display area is used to turn on or off the display of the geometry elements. 

 The Annotate area is used to turn on and off the text data associated with the geometry 
elements.

Lab 3.3 - Display or Annotation of Cogo Points

Section Objectives:

 Illustrate a method for defining cogo points for display and/or annotation.

Note: Whether you are annotating Points or Alignments, keep in mind that the element 

selection button can be used to graphically identify the geometry of interest. 
This is universally true in InRoads whenever the selection button is displayed.

10. <D> the Include field in the Cogo Points area to activate the Filter button
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11. <D> the Filter button. The Geometry Selection Filter dialog box is displayed.

12. Select points 1001-1005 & 1010 from the Available field and add them to the Selected 
field.

13. <D> the OK button. The points populate the Selected field.

14. <D> OK to dismiss the Geometry Selection Filter dialog box and populate the Cogo 
Points Selected field of the View Horizontal Annotation dialog box.
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15. <D> the Apply button in the View Horizontal Annotation dialog box.

16. Experiment displaying various Alignments and Points with the assorted settings.

17. Close the View Horizontal Annotation dialog box.
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Section Summary:

 Cogo Points can be selected for annotation by key in, graphic selection using the  
button, or by using the Filter options.

  In the Display area, the Points toggle is used to turn on or off the display of the geometry 
points.

 The Annotate area is used to turn on and off the text data associated with the geometry 
elements.

Lab 3.4 - Displaying Stationing

Section Objectives:

 Display stationing and alignment keypoints.

 Use the Symbology toggles to turn on and off various items.

1. Prior to displaying the stationing, display the linework for the horizontal alignment SH 
86_West.

Right-click on the alignment name in the InRoads explorer pane and select View from the 
right click menu.
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2. Select Geometry > View Geometry > Stationing. The View Stationing dialog box 
is displayed.

3. <D> the Preferences button.

Note: The Preferences dialog box is used to load predefined settings for a particular tool. 
In the View Stationing dialog box the preference sets the interval and symbology 
of the display graphics.

The following steps load the Preference Proposed–100 Ft Interval as the active symbology.

4. <D> Proposed-100 Ft Interval.

5. <D> Load then Close button.
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6. Using the dialog box explorer, select or de-select alignment stationing components for 
display. 

7. <D> Apply to display the stationing.

The View Stationing dialog box is populated with the predefined settings from the 
preference. The display toggles define what will display; the name column identifies the 
named symbology used for that station type.
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There are several standard CDOT preferences to choose from. These are based on the type 
of alignment and station interval. Choose the appropriate Preference and <D> Apply to 
see the stationing.

Keep in mind that text size is dependent on the active Global Scale Factor at time of 
display. If necessary, select File > Project Options [Factors] to change the value of the 
Global Scale factors.

8. Change the Global Scale Factor and redisplay stationing.

9. Experiment displaying stationing using various CDOT preferences.

10. Experiment with the various settings in the View Stationing dialog box and investigate 
what changes are made when stationing is redisplayed.

Section Summary:

 The stationing Preferences are set to CDOT standards and should be used in most cases.

 Using the Pencil mode automatically deletes old stationing when new stationing is 
displayed.

Lab 3.5 - Defining Stationing

Section Objectives:

 Change the beginning station of an alignment.

Upon creation, alignments are defined with a beginning stationing of 0+00. Stationing can be 
redefined from any location along the alignment. 

1. Select Geometry > Horizontal Curve Set > Stationing. By default, this dialog box 
displays the beginning station value of the active alignment.

2. Verify that SH86_West is set as the Horizontal Alignment.

3. Select Synchronize Starting Stations in the Vertical and Superelevation Alignments 
section.
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Important! Do not use this option if any of the vertical alignments associated with the 
horizontal do not start at the beginning of the horizontal alignment. Using 
this option will move those vertical alignments that start after the 
beginning of the horizontal alignment to the beginning station of the 
horizontal alignment.

4. In the Starting Station field, key in 125+25.36 then <D> the Apply button.

5. Verify the change has been applied by redisplaying the stationing. Also, check the 
beginning station value of the associated vertical alignments by using the review 
command.

Note: The options for Vertical Alignments should be considered carefully. Do Not 
Update will leave the stationing of vertical application stations as is, 
Synchronize Starting Stations will update their stationing to match that of the 
horizontal and Maintain Station Difference will keep any difference (delta) in 
the current starting stations.

○ InRoads does not require a ‘+’ when keying in a station. The plus sign will be 
added automatically.

○ Stationing can be set from any alignment point. If the point selected is not the 
POB, the stationing is computed for the POB from the selected point.

Section Summary:

  When stationing is set for a particular point, the stationing for the remainder of the 
alignment (forwards and backwards).

 The reference to Superelevation in the Vertical and Superelevation Alignments area refers 
to geometry created in the 2004 edition of InRoads. It does not affect the superelevation 
contained in the Roadway Designer.
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Lab 3.6 - Station Equations

If there are inequalities in the alignment, station equations may be required. These equations 
can be either gap or overlap equations.

Section Objectives:

 Add a station equation to an existing alignment.

 Redisplay stationing to show the station equation.

1. From MicroStation, select Utilities > Saved Views. 

2. Highlight the Station Equation saved view and <D> Apply then Close the Saved View 
dialog box.
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At the PT of the curve a station equation is necessary to tie to previous work. The values 
are: 
Back   = 359+22.81
Ahead = 359+27.81

3. Select Geometry > Horizontal Curve Sets > Stationing to display the Stationing 
dialog box.

4. Verify SH 86_West is the horizontal alignment.

5. At the bottom of the dialog box, choose New. The Add Station Equation dialog box is 
displayed.

 

6. In the Add Station Equation dialog box, set the Mode to By Station.

7. Enter the Back Station and the Ahead Station as shown below.

 

8. <D> Apply.

Note: The ahead station must be prefixed with an equation name. The name must consist 
of at least one alpha character.

○ An alignment can contain multiple station equations.
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○ Annotation of stationing lying within the range of a station equation will be 
prefixed with the equation name. The toggle Drop Station Equation Name in the 
General leaf of the View Stationing dialog box is on so that the equation name is 
not displayed.

9. <D> Close to dismiss the Add Station Equation dialog box. The station equation is 
shown in the parent dialog box.

10. <D> Close in the Stationing dialog box.

11. Redisplay the stationing for alignment SH 86_West.

Notice that the station equation text is on top of the PC station text. To fix this problem:

12. Select Geometry > View Geometry > Stationing.

13. Select the Station Equation leaf.
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14. Toggle the Placement to Out.

15. <D> Apply to redisplay the stationing.

The equation is now displayed on the opposite side of the alignment from the PC stationing 
text.

Section Summary:

 Station equations are used to change the stationing from a given spot forward, along the 
alignment. Stationing prior to the equation retains its original stationing.

 The ahead station must have a prefix, containing at least 1 letter, followed by the new 
station number.
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Lab 3.7 - Horizontal Alignment Tracking

Two methods exist for receiving interactive information relative to a horizontal alignment. 
These are Tracking and Horizontal Alignment Tracking. Both methods report on stationing, 
offset, elevation, etc. Tracking reports the elevation of the active surface, Horizontal Alignment 
Tracking reports the elevation of the active vertical alignment.

Section Objectives:

 Demonstrate the Tracking command.

 Demonstrate the Tracking Horizontal Alignments command

Tracking (horizontal alignment and surface data)

1. Recall Saved View Side Road.

2. If the Side Road alignment is not visible, display it.

Tracking reports on station and offset information relative to the active alignment along 
with information relative to the active surface.

3. Select File > Open and load the surface 12345SURV_Existing_Ground.dtm from the 
C:\Projects\12345\ROW_Survey\InRoads\DTM folder. 

To display the surface features from the existing ground dtm:

4. Select Surface > View Surface > Features.
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5. <R> in the Features list and <D> Select All.

6. <D> Apply then Close.

Displaying surface features is a good way to orient yourself to the location you are at in the 
model.

7. Select Tools > Tracking > Tracking to track both the active horizontal alignment and 
information relative to the active surface.

Note: This command will display information about any data that is present. Neither 
geometry or a dtm are required to get some feedback from this command.
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8. Select Activate to initialize the command. Slide the cursor along the alignment to 
interactively update the display in the Tracking dialog box. If a <D> (data point) is 
entered in the design file the information toggled on is displayed graphically.

Note: Select the Settings button in the Tracking dialog box to examine the attributes 
assigned to annotation placed in the MicroStation design file.

Horizontal Alignment Tracking (with vertical alignment data)

This tracks the station and offset relative to the active horizontal alignment along with the 
elevation of the active vertical alignment. Station, Offset, and Elevation information is 
displayed in the message field of the InRoads interface. Note: A horizontal alignment must be 
present for this command to work.
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1. Select Tools > Tracking > Horizontal Alignment to track the active horizontal align-
ment.

The results display at the cursor and in the status bar of the InRoads interface.
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Note: The readout interactively reflects the location of the cursor relative to the active 
alignment. If a second horizontal alignment is selected with a data point, the offset 
displayed will be the distance to intersect the selected alignment from the active 
alignment, perpendicular to the active alignment.

Section Summary:

 Use the Tracking command to get surface information in relation the horizontal alignment.

 The Tracking command can be used to display the information in its dialog box as 
MicroStation graphics. 

 The tracking Settings options are used to enable and disable the graphic display of items in 
the Tracking dialog box.

 Use the Horizontal Alignments tracking to get vertical alignment information in relation 
the horizontal alignment.

 Horizontal Alignments tracking can not be displayed graphically.

Chapter Summary:

 Horizontal alignments can be displayed using the View and View All Horizontals from the 
right click menu or from the main tool bar, or by using the horizontal alignment annotation 
command.

 Use the preferences to set up the Stationing dialog box. Items in the Stationing dialog box 
should only be changed for special circumstances.

 Use the Stationing options under the Horizontal Curve Set commands to change the 
stationing for the entire alignment.

 Use station Equations to change the stationing from a point on the alignment to the end.

 Tracking is used to gain station and offset information at the cursors location.
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 Tracking also collects surface data, while Horizontal Alignment tracking gets vertical 
alignment data.
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